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Importing a pre-drawn map

This section explains how to import an axial map which has been
saved in DXF format.
The DXF is just a line drawing, so it must be converted to an axial
map before measures can be calculated from it.
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New file

First, begin a ‘New’ file, either from the file menu or using the
‘New’ button on the toolbar.
You cannot open a DXF file or other drawing file directly, you
always need to create a new file and import.
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Import file

Once you have the new file, select ‘Import’, either from the layer
menu, or using the import button on the toolbar.
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Import file

In the examples, there is a pre-drawn axial map saved as
‘bansbury axial.dxf’. We will use this file for this section of the
tutorial.
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Convert to axial map

When the DXF file is imported, it comes in simply as a drawing.
We need to convert to an axial map. To do so, choose ‘Convert
Drawing Layers...’ from the layer menu.
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Convert to axial map

You are given a range of options for the type of file you want to
create.
Choose ‘Axial Map’ from the drop down menu.
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Convert to axial map

After you have selected ‘Axial Map’ you can give the new axial map
a name. I have left it as the default ‘Axial Map’.
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Axial map analysis

After choosing ‘OK’, will see the axial map coloured up by
‘Connectivity’ (the number of lines which each line intersects).
However, the space syntax analysis has not been performed yet.
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Axial map analysis

To find the space syntax value of integration and other measures,
find the ‘Point / Axial / Convex’ graph tools on the ‘Tool’ menu.
Beneath it there are several options. Choose ‘Run Graph Analysis’.
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Axial map analysis

You are given a number of options, which are explained further in
the Depthmap Researcher’s Handbook.

http://www.vr.ucl.ac.uk/depthmap/handbook.html
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Axial map analysis

I have just chosen the default analysis: a radius n (whole system)
analysis, which gives a number of results. ‘Integration [HH]’ is
integration as described in the Social Logic of Space (HH stands for
Hillier and Hanson).
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Axial map analysis

Letting the mouse cursor hover while it points to a line will give the
integration value for that line.
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Step depth

Another measure you may want to calculate is ‘Step Depth’. To do
this, first select the line from which you want to calculate the depth,
by clicking on it in the standard ‘Select’ mode.
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Step depth

Now, either select ‘Step Depth’ from the ‘Tools’, ‘Point / Axial /
Convex’ menu, or use the ‘Step Depth’ button on the toolbar as
shown above.
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Step depth

The line itself has depth 0, it is the line from which the calculation
is made.
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Step depth

All lines connected to the base line are at depth 1. They are one
turn away from the base line. All lines connected to them are at
depth 2, and so on.
Note that this forms the basis of the radius in Depthmap: radius 2
is everything up to and including two turns from the base line (as
you might expect). This corresponds to radius 3 in Axman, which
includes the base line as the first step.
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Editing the map

This section covers:

I Modifying the position of the axial lines

I Unlinking lines (for example, where there is a bridge)

I Linking lines (for example, on different floors)
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Modifying lines

When you have processed the map, you may find that lines that
were supposed to be connected were not drawn correctly. At this
point you may want to edit the map.
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Modifying lines

To prevent accidental moving of the lines, by default the map is not
editable. Select ‘Editable On’ by clicking on the box on the sidebar.
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Modifying lines

Now select the line you want to alter. In editable mode, two boxes
(usually called ‘handles’) are added to each of the line. Click once
on the handle in order move the end of the line.
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Modifying lines

Now move the mouse until the line is in the position you want it
and click again. If you prefer, rather than clicking once to pick up
and again to drop, you can click and drag the position of the line.
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Modifying lines
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Modifying lines

Once you have moved the line, it may be prudent to switch the
attribute displayed to ‘Connectivity’ using the link on the sidebar.
This shows that the line now intersects two others, rather than one
as before, and the link has been made correctly.
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Unlinking lines

You may need to unlink lines, for example, where roads cross at
different heights. To do this, select ‘Unlink’ mode from the drop
down menu on the tool bar.
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Unlinking lines

Select the lines you want to unlink one at a time.



Depthmap Axial

Alasdair Turner

Importing a pre-drawn map

Editing the map

Automatically generating an
axial map

Hand drawing an axial map

Conclusion

Unlinking lines

As soon as you click on the second line to unlink, the lines are
unlinked. This is symbolised by a small red circle at the intersection
of the lines. Notice that the connectivity for the lines is reduced as
soon as they are unlinked.
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Linking lines

In order to link to otherwise unlinked lines (for example, separated
by a tunnel, or on different floors of a building), change the mouse
mode to ‘Link’ by selecting the ‘Link’ from the drop down menu on
the toolbar (or usually, by selecting link directly).
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Linking lines

Select the lines which are linked on at a time. If you need to link
two lines which are separated, while you are in this mode, you can
pan by holding down the right mouse button, and zoom in and out
using the scroll wheel on the mouse if you have one.
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Linking lines

When you select the line to join to, a green line is shown which
represents the join.
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Linking lines

The connectivity is updated as soon as the lines are joined.
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Linking lines

Despite the fact that connectivity is updated immediately, the
analysis measures are not updated. You must reanalyse to find the
new measure of integration.
Notice that in selection mode, the links and unlinks are not shown:
if you wish to see them, change to either ‘Link’ or ‘Unlink’ mode.
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Linking lines

To reanalyse, select ‘Run Graph Analysis’ from the ‘Tools’ menu as
before. The old figures will be overridden.
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Linking lines

Note that the integration of this line has changed from 1.73276 to
1.76213.
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Automatically generating an axial map

This section describes how to create an axial map automatically
from a layout in DXF format.
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Import outline map

In order to create an axial map automatically, we need a map of the
open space of the system. Start by creating a new graph file, by
selecting ‘New’ from the toolbar, or from the ‘File’ menu.
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Import outline map

Next, select ‘Import’, either from the ‘Layer’ menu, or using the
‘Import’ button on the main toolbar.
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Import outline map

For this section of the tutorial, we will use ‘barnsbury centre.dxf’,
which contains a plan of the open space in the Barnsbury area of
North London.
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Import outline map

Notice how the map has a closed border, which allow us to contain
the generated axial lines, much like a VGA analysis (see the
Depthmap Basics tutorial) would require a closed border to contain
the visibility graph.

http://www.vr.ucl.ac.uk/depthmap/tutorials/
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Generate all-line map

The first phase of generating the axial map will be to generate an
all-line axial map. To create this map, select the ‘Axial Map’ tool on
the map toolbar as shown above.
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Generate all-line map

Once the tool is selected, an ‘eye-dropper’ cursor is presented. This
is to allow us to seed the axial map in open space, just as we would
flood fill open space in a VGA analysis.
Click on some open space with the eye-dropper tool. Note that
sometimes it does not work, and you may need to try seeding the
axial map in a different place.
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Generate all-line map
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Generate all-line map: detail

The all-line map joins all pairs of inter-visible vertices in the map.
As such, the number of lines vary with the level of detail of the
map, and it therefore has limited use.
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Reduction to fewest-line map

The all-line map can be reduced to a ‘fewest-line map’, by selecting
‘Reduce to Fewest-Line Map’ from the ‘Point / Axial / Convex’
tools menu.
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Fewest-line maps

A fewest-line map attempts to cover the system with as few lines as
possible which both (a) allow any part of the system to be seen
from a line, and (b) ensure the depth between all pairs of lines is
minimised.
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Fewest-line map variants

Depthmap offers two versions of the fewest-line map. These are
best compared by turning off the open space border, by clicking on
the ‘eye’ icon by for the drawing layer on the sidebar.
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Fewest-line (subsets)

The subset version of the fewest-line map is a uniquely defined set
of lines, which maintains the shortest paths around objects. This
might be viewed as the ‘technically correct’ version of the axial map.
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Fewest-line (subsets)

Notice how in this version of the map, the lines around the square
keep the shortest path from one side of the square to the other,
while also fully surrounding the square with lines.
(Details about why these lines and not others are drawn can be
found in ‘An algorithmic definition of the axial map’)

http://eprints.ucl.ac.uk/624/
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Fewest-line (minimal)

The minimal version of the fewest-line map reduces the number of
lines in the subset version further, by removing the extra depth
minimising lines. This gives a more natural version of the axial map,
which approximates well what researchers have drawn over the years.
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Fewest-line (minimal)

Note how in the detail of the square, the two lines providing the
shallower crossing of the square have been removed in this case.
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Hand drawing an axial map

Although the automatic generation of axial maps may be preferred
for simple plans, complex plans take too long to analyse, and
hand-drawing may be easier.
This section describes how to draw an axial map using Depthmap’s
line drawing tool, over a background imported in DXF format.
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Import outline map

As with the automatic generation of lines example, we start by
importing the outline of the Barnsbury area.
(See the last section for details of the import process.)
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Create new axial map

In order to create an axial map, we create a new layer into which to
draw it. Select ‘New’ from the ‘Layer’ menu.
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Create new axial map

In order to create an axial map, we create a new layer into which to
draw it. Select ‘New’ from the ‘Layer’ menu.
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Create new axial map

From the drop down menu for the layer type, select ‘Axial Map’.
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Create new axial map

We are given the opportunity to change the layer name for the map
if we wish.
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Drawing axial lines

Once the new layer has been created, select the ‘Line’ tool from the
map toolbar in order to axial lines.
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Drawing axial lines

Place the cross cursor and click once to start the line.
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Drawing axial lines

Click a second time to finish the line. Alternatively, you can click
and drag to draw the line rather than clicking twice.
If you wish to abort the line while drawing, right-click rather than
left-clicking.
You can also undo the line by choosing Ctrl-Z, or ‘Undo’ from the
‘Edit’ menu. In addition, you can delete the line by selecting it and
then pressing the ‘Del’ key, or ‘Clear’ from the ‘Edit’ menu.
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Drawing axial lines

Whilst you are drawing a line, you can zoom out using the mouse
scroll wheel, or pan by holding down the right mouse button and
dragging the mouse.
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Drawing axial lines
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Drawing axial lines

As soon as you draw an axial line, the connectivity is recalculated.
However, as with editing imported axial maps, after you draw a new
line you will need to recalculate the graph measures.
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Conclusion

This tutorial has covered the basics of axial map creation and
analysis in Depthmap. More information on measures and
algorithms can be found in the Depthmap Researcher’s Handbook.

http://www.vr.ucl.ac.uk/depthmap/handbook.html
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